Questo sito utilizza cookies, anche di terze parti, per mostrare pubblicità e servizi in linea con il tuo account. Leggi l'informativa sui cookies.
Username: Password: oppure
PHP - APACHE 2.2 MYSQL 4.1 PHP 5.2.6
Forum - PHP - APACHE 2.2 MYSQL 4.1 PHP 5.2.6

Avatar
FastPSP (Normal User)
Newbie


Messaggi: 4
Iscritto: 27/10/2006

Segnala al moderatore
Postato alle 22:27
Lunedì, 21/07/2008

Ragazzi ho disinstallato PHPTriad ed ho deciso di installare singolarmente apache php e mysql.

Sembrava girare!

fino al quando mi accorgo che un mio sito fatto in php che ha sempre girato tranquillamente e che oggi giorno funziona ancora e benissimo (su altervista.org)

non mi gira bene nel mio nuovo ambiente e per la precisione mi è sembrato di capire da un mio debug personale
che sembra proprio che la mysql_query() sia l'indagata al crimine.

Come posso fare per risolvere?
Ho provato a vedere la funzione direttamente su php.net per vedere ancora c'era da fare una nuova modifica al php.ini o aggiungere una estensione

avevo pensato all'estensione php_mysqli.dll....ma secondo me non è quello il problema.

Qualcuno ha gia affrontato un problema simile?

Ho provato a reistallare phptriad e funziona:
le righe nelle tabelle me le inserisce tranquillamente ecc....

PER LA PRECISIONE HO NOTATO CHE:

il form di login:

..
query=mysql_query("SELECT * FROM condomini WHERE user='$user' AND pwd='$pwd'");
$num=mysql_num_rows($query);
if($num != 1){
...

non mi da mai 1 anche se i dati sono corretti.

invece in una query di inserimento:

mysql_query("INSERT INTO personale (matricola,grado,cognome,nome,....) VALUES (....)"....ECC ECC

mi inserisce una riga vuota nella tabella...

non so come risolvere questo problema...

PM Quote