Questo sito utilizza cookies, anche di terze parti, per mostrare pubblicità e servizi in linea con il tuo account. Leggi l'informativa sui cookies.
Username: Password: oppure
PHP - Problema sessioni con internet Explorer
Forum - PHP - Problema sessioni con internet Explorer

Avatar
Cristian Sannino (Ex-Member)
Rookie


Messaggi: 26
Iscritto: 12/02/2011

Segnala al moderatore
Postato alle 9:29
Mercoledì, 16/03/2011
salve a tutti come da titolo ho un Problema con internet Explorer che non memorizza ne sessioni ne cookie, avete qualche idea in merito ?
Grazie in anticipo


http://www.cristiansannino.com : Tutorial, articoli e news inerenti il mondo della programmazione !
PM Quote
Avatar
Thejuster (Member)
Guru^2


Messaggi: 1704
Iscritto: 04/05/2008

Segnala al moderatore
Postato alle 10:40
Mercoledì, 16/03/2011
uhm, non saprei,
inizialmente anche io avevo un problema del genere,
se non sbaglio c'è un opzione in IE che blocca i cookie,

di più non saprei dirti, perché evidentemente è un problema del tuo browser.

prova a fare una ricerca su google.


PM Quote
Avatar
Cristian Sannino (Ex-Member)
Rookie


Messaggi: 26
Iscritto: 12/02/2011

Segnala al moderatore
Postato alle 11:01
Mercoledì, 16/03/2011
Fatto una marea di ricerche ed ho capito solo che le sessioni con php, non funzionano con ie, ma con qualche tips andrebbe tipo header particolari etc
Ma poi tra l'altro ho utilizzato pure i cookie su Mozilla,safari e chrome funzionano entrambi i metodi ma su ie non va


http://www.cristiansannino.com : Tutorial, articoli e news inerenti il mondo della programmazione !
PM Quote
Avatar
Thejuster (Member)
Guru^2


Messaggi: 1704
Iscritto: 04/05/2008

Segnala al moderatore
Postato alle 11:07
Mercoledì, 16/03/2011
vabbe che IE non lo definisco nemmeno un browser,
diciamo che per me IE e la strada di accesso ai milioni di Adware, spyware e trojan.

c'è l'ho solo tanto per averlo.


PM Quote
Avatar
Cristian Sannino (Ex-Member)
Rookie


Messaggi: 26
Iscritto: 12/02/2011

Segnala al moderatore
Postato alle 11:23
Mercoledì, 16/03/2011
Purtroppo è una richiesta del cliente : compatibilità con tutti i browser


http://www.cristiansannino.com : Tutorial, articoli e news inerenti il mondo della programmazione !
PM Quote
Avatar
Cristian Sannino (Ex-Member)
Rookie


Messaggi: 26
Iscritto: 12/02/2011

Segnala al moderatore
Postato alle 22:22
Sabato, 02/04/2011
Ok ho risolto, il problema era che invece del bottone submit nel form avevo delle immagine che davano il submit ed in qualche modo era come se le immagini ripulivano le sessioni, sembra essere un bug di Internet Explorer, ma adesso ho risolto. Poi attenzione al register globals nel php.ini se settato su on può dare problemi con sessioni e cookie.
Rispondo alla mia domanda per essere utile a chi ne avrà bisogno e troverà questo post :k:


http://www.cristiansannino.com : Tutorial, articoli e news inerenti il mondo della programmazione !
PM Quote