Questo sito utilizza cookies, anche di terze parti, per mostrare pubblicità e servizi in linea con il tuo account. Leggi l'informativa sui cookies.
Username: Password: oppure
Guida al Visual Basic .NET - IDE  Uno sguardo approfondito

Guida al Visual Basic .NET

Capitolo 52° - IDE Uno sguardo approfondito

<< Precedente Prossimo >>

N.B.: a causa di una incompatibilità nelle query, tutti i capitoli che seguono sono privi di immagini. Potete accedere alla versione integrale e completa della guida sul mio sito.

Fino ad ora ci siamo serviti dell'ambiente di sviluppo integrato - in breve, IDE - come di un mero supporto per lo sviluppo di semplici applicazioni console: ne abbiamo fatto uso in quanto dotato di editor di testo "intelligente", un comodo debugger e un compilatore integrato nelle funzionalità. E non potrete negare che anche solo per questo non ne avremmo potuto fare a meno. Tuttavia, iniziando a sviluppare applicazioni dotate di GUI (Graphical User Interface) a finestre, l'IDE diventa uno strumento ancora più importante. Le sue numerose features ci permettono di "disegnare" le finestre del programma, associarvi codice, navigare tra i sorgenti, modificare proprietà con un click, organizzare le varie parti dell'applicativo, eccetera eccetera... Prima di introdurvi all'ambito Windows Forms, farò una rapida panoramica dell'IDE, più approfondita di quella proposta all'inizio.


Primo impatto

Fate click su File > New Project, scegliete "Windows Form Application" e, dopo aver scelto un qualsiasi nome per il progetto, confermate la scelta. Vi apparirà una schermata più o meno simile a quella che segue:

NewWindowsFormApplication.jpg
Non vi allarmate se manca qualcosa, poiché i settaggi standard dell'IDE saranno molto probabilmente diversi da quelli che uso io. L'interfaccia dell'ambiente di sviluppo, comunque, è completamente customizzabile, dato che è anch'essa strutturata a finestre: potete aggiungere, rimuovere, fondere o dividere finestre semplicemente trascinandole con il mouse. Ecco un esempio di come manipolare le parti dell'IDE in questo video.


Menù principale

Il menù principale è costituito dalla prima barra di voci appena sotto il bordo superiore della finestra. Esso permette di accedere ad ogni operazione possibile all'interno dell'IDE. Per ora ci serviremo di questi:

  • File: il menù File permette di creare nuovi progetti, salvarli, chiudere quelli correnti e/o aprire file recenti;
  • Edit: contiene le varie operazioni effettuabili all'interno dell'editor di testo: taglia, copia, incolla, undo, redo, cerca, sostituisci, seleziona tutto eccetera...
  • View: i sottomenù consentono di nascondere o visualizzare finestre:

    IDEViewMenu.jpg
    Code permette di visualizzare il codice sorgente associato a una finestra; Designer porta in primo piano l'area riservata alla creazione delle finestre; Database explorer permette di navigare tra le tabelle di un database aperto nell'IDE; Solution Explorer consente di vedere le singole parti del progetto (vedi paragrafo successivo); Error List visualizza la finestra degli errori e Properties Window quella delle proprietà. Il sottomenù di Toolbars permette di aggiungere o rimuovere nuove categorie di pulsanti alla barra degli strumenti. Le altre voci per ora non ci interessano;
  • Project : espone alcune opzioni per il progetto ed in particolare consente di accedere alle proprietà di progetto;
  • Build : fornisce diverse opzioni per la compilazione del progetto e/o della soluzione.

Infine, cone Tools > Options, potrete modificare qualsiasi opzione riguardante l'ambiente di sviluppo, dal colore del testo nell'editor, agli spazi usati per l'indentazione, all'autosalvataggio, eccetera... (non vale la pena di analizzare tutte le voci disponibili, perchè sono veramente troppe!).


Solution Explorer

La finestra denominata "Solution Explorer" permette di navigare all'interno della soluzione corrente e vederne le varie parti. Una soluzione è l'insieme di due o più progetti, o, se si tratta di un progetto singolo, coincide con esso.

SolutionExplorer1.jpg
Come vedete ci sono cinque pulsanti sulla barra superiore: il primo permette di aprire una finestra delle proprietà per l'elemento selezionato; il secondo visualizza tutti i files fisicamente esistenti nella cartella della soluzione, il terzo aggiorna il solution explorer (nel caso di files aggiunti dall'esterno dell'IDE), mentre quarto e quinto permettono di passare dal codice al visual designer e viceversa. Premendo il secondo pulsante, potremo ossevare che c'è molto più di ciò che appare a prima vista:

SolutionExplorer2.jpg
La prima cartella contiene dei files che vanno a costruire uno dei namespace più utili in un'applicazione windows, My, di cui ci occuperemo nella sezione C. La seconda cartella mostra l'elenco di tutti i riferimenti inclusi nel progetto: il numero e il tipo di assembly importati varia a seconda della versione dell'IDE e nella 2008 quelli elencati sono gli elementi di default. Per i nostri progetti, solamente tre saranno di vitale importanza: System, System.Drawing e System.Windows.Forms. Potete rimuovere gli altri senza preoccupazione (questo ci farà risparmiare anche un megabyte di RAM). La cartella bin contiene a sua volta una o due cartelle (Debug e Release) in cui troverete il programma compilato o in modalità debug o in modalità release. obj, invece, è dedicato ai file che contengono il codice oggetto, una serie di bytes molto simili al codice compilato, ma ancora in attesa di essere assemblati in un unico eseguibile.
Dopo tutti questi elementi, che per ora ci interessano poco, troviamo la Form1, di default la prima finestra dell'applicazione. Possiamo notare che esiste anche un altro file, oltre a Form1.vb (in cui è contenuto il codice che scriviamo noi): Form1.Designer.vb. Quest'ultimo sorgente è prodotto automaticamente dal Designer e contiene istruzioni che servono a inizializzare e costruire l'interfaccia grafica; in esso sono anche dichiarati tutti i controlli che abbiamo trascinato sulla form. Ogni form, quindi, è costituita da due file sorgenti diversi, i quali contengono, tuttavia, informazioni sulla stessa classe (Form1 in questo caso). Se ricordate, avevo detto che esiste una particolare categoria di classi che possono essere scritte su file diversi: le classi parziali. In genere, infatti, le forms sono classi parziali, in cui il codice "grafico" viene tenuto nascosto e prodotto dall'IDE e il codice di utilità viene scritto dal programmatore.


Finestra delle proprietà

Contiene un elenco di tutte le proprietà dell'elemento selezionato nel designer e permette di modificarle direttamente dall'ambiente di sviluppo. Il box sottostante contiene anche una breve descrizione della proprietà selezionata.

PropertiesWindow.jpg
Premendo il pulsante con l'icona del fulmine in cima alla finestra, si aprirà la finestra degli Eventi, che contiene, appunto, una lista di tutti gli eventi che il controllo possiede (vedi prossimo capitolo).


<< Precedente Prossimo >>
A proposito dell'autore

Programmatore e analista .NET 2005/2008/2010 (in particolare C# e VB.NET), anche nell'implementazione Mono per Linux. Conoscenze approfondite di Pascal, PHP, XML, HTML 4.01/5, CSS 2.1/3, Javascript (e jQuery). Conoscenze buone di C, LUA, GML, Ruby, XNA, AJAX e Assembly 68000. Competenze basilari di C++, SQL, Hlsl, Java.