Questo sito utilizza cookies solo per scopi di autenticazione sul sito e nient'altro. Nessuna informazione personale viene tracciata. Leggi l'informativa sui cookies.
Username: Password: oppure
PHP - errore tema wordpress in
Forum - PHP - errore tema wordpress in

Avatar
alex1995 (Normal User)
Expert


Messaggi: 288
Iscritto: 27/01/2011

Segnala al moderatore
Postato alle 16:10
Venerdì, 27/05/2022
salve, ho creato un tema per wordpress con artisteer che ho comprato ma non mi danno assistenza. uso xampp ultima versione con php8 col php7 non succede ma ho bisogno che funzioni con l' 8... sono un mediocre programmatore php e non sono capace di sistemare l' errore.
l' errore è questo:

Codice sorgente - presumibilmente VB.NET

  1. hi i use the latest version of wordpress with php 8 and i recive this error when i select the theme created with artisteer 4.3 Fatal error: Uncaught ArgumentCountError: Too few arguments to function WP_Widget::__construct(), 0 passed in C:\xampp\htdocs\wp-includes\class-wp-widget-factory.php on line 61 and at least 2 expected in C:\xampp\htdocs\wp-includes\class-wp-widget.php:162 Stack trace: #0 C:\xampp\htdocs\wp-includes\class-wp-widget-factory.php(61): WP_Widget->__construct() #1 C:\xampp\htdocs\wp-includes\widgets.php(115): WP_Widget_Factory->register('VMenuWidget') #2 C:\xampp\htdocs\wp-content\themes\mytheme\library\widgets.php(255): register_widget('VMenuWidget') #3 C:\xampp\htdocs\wp-includes\class-wp-hook.php(307): artWidgetsInit('') #4 C:\xampp\htdocs\wp-includes\class-wp-hook.php(331): WP_Hook->apply_filters('', Array) #5 C:\xampp\htdocs\wp-includes\plugin.php(474): WP_Hook->do_action(Array) #6 C:\xampp\htdocs\wp-includes\widgets.php(1854): do_action('widgets_init') #7 C:\xampp\htdocs\wp-includes\class-wp-hook.php(307): wp_widgets_init('') #8 C:\xampp\htdocs\wp-includes\class-wp-hook.php(331): WP_Hook->apply_filters(NULL, Array) #9 C:\xampp\htdocs\wp-includes\plugin.php(474): WP_Hook->do_action(Array) #10 C:\xampp\htdocs\wp-settings.php(587): do_action('init') #11 C:\xampp\htdocs\wp-config.php(90): require_once('C:\\xampp\\htdocs...') #12 C:\xampp\htdocs\wp-load.php(50): require_once('C:\\xampp\\htdocs...') #13 C:\xampp\htdocs\wp-blog-header.php(13): require_once('C:\\xampp\\htdocs...') #14 C:\xampp\htdocs\index.php(17): require('C:\\xampp\\htdocs...') #15 {main} thrown in C:\xampp\htdocs\wp-includes\class-wp-widget.php on line 162



questo è il sorgente del file widgets.php
https://pastebin.com/sJLP7rrN

c' è qualche anima pia che può aiutarmi?

Ultima modifica effettuata da alex1995 il 27/05/2022 alle 16:13
PM Quote