Questo sito utilizza cookies, anche di terze parti, per mostrare pubblicità e servizi in linea con il tuo account. Leggi l'informativa sui cookies.
Username: Password: oppure
PHP - Utilizzo forum in phpBB
Forum - PHP - Utilizzo forum in phpBB

Avatar
()
Newbie


Messaggi:
Iscritto:

Segnala al moderatore
Postato alle 1:00
Giovedì, 01/01/1970
Salve a tutti,
Ho installato sul mio sito (hosta su Altervista) un forum phpBB, ma non so come usarlo.
Sapreste aiutarmi?
Vorrei poter personalizzare un po' la grafica, aggiungermi come amministratore (quando ho installato il forum mi è apparsa una finestra con un'utente e una password, ma poi è partito il pc :_doubt: ) e modificare le varie sottosezioni.
Chiedo troppo? :(
Dove devo mettere le mani?

Ultima modifica effettuata da il 25/02/2011 alle 20:33
PM Quote
Avatar
()
Newbie


Messaggi:
Iscritto:

Segnala al moderatore
Postato alle 21:01
Venerdì, 25/02/2011
Fortunamente Altervista mi ha mandato una mail coi dati di amministrazione :rofl:
Guardando un po' il php delle pagine che mi ha installato, ho visto che il logo della pagina lo prende dal file site_logo.gif di una data cartella, ma c'è in più cartelle!
Lo dovrei cambiare in tutte?

PM Quote
Avatar
XBarboX (Member)
Guru


Messaggi: 945
Iscritto: 31/12/2008

Segnala al moderatore
Postato alle 8:43
Sabato, 26/02/2011
Allora,
phpBB è molto semplice da usare.

Per amministrare il tutto devi andare sul PCA (Pannello di controllo dell'amministratore).
Torvi il link per questo strumento di amministrazione in fondo alla pagina dopo esserti loggato come amministratore.

Successivamente per modificare il forum usa un po di pazienza e di logica e vedrai che riuscirai a fare tutto quello che vuoi senza problemi.

Per cambiare lo stile del forum, o scarichi nuovi temi (ci sono un sacco di siti con temi carini. Uno ben fatto è http://demo.phpbb3styles.net/)

Infine ho notato che vuoi cambiare l'header della pagina. Niente di più facile.
Crei un'immagine dell'header e la chiami come vuoi.
Poi la carichi in /styles/tuo_tema/imageset/  e successivamente vai nel pca clicca sulla tab stili  e poi su set-immagini. Poi clicca sul link modifica del tuo tema e come logo principale scegli la tua immagine appena caricata.

Se vuoi in fretta crea un'immagine site_logo.gif e la carichi sovrascrivendo l'altra.

IMPORTANTE: dopo ogni modifica che fai ricorda di cancellare tutti i file nella cartella cache


The old lie: Dulce et decorum est pro patria mori
PM Quote
Avatar
()
Newbie


Messaggi:
Iscritto:

Segnala al moderatore
Postato alle 14:07
Sabato, 26/02/2011
Grazie per i preziosi consigli XBarboX :k:
Ti volevo chiedere, io ho aggiunto dei forum dal pannello "Gestione Forum" nel PCA, ma se apro l'index del forum (file index.php per intenderci) non me li visualizza.
Come mai?
Può essere a causa dei permessi? Come si modificano? (quel menu è l'unico in cui non ho capito una mazza :-|)

PM Quote
Avatar
XBarboX (Member)
Guru


Messaggi: 945
Iscritto: 31/12/2008

Segnala al moderatore
Postato alle 14:55
Sabato, 26/02/2011
Allora, il difficile di phpbb è di impostare bene i permessi dei forum.
Spiegarlo a parole è difficile. Faresti meglio a fare riferimento a qualche guida sul web.
Questo video sembra fatto bene: http://www.phpbb.com/support/tutorials/3.0/index.php?tid=6

E qua trovi preziosi tutorial:
http://www.phpbb.com/support/tutorials/3.0/


The old lie: Dulce et decorum est pro patria mori
PM Quote
Avatar
Thejuster (Member)
Guru^2


Messaggi: 1703
Iscritto: 04/05/2008

Segnala al moderatore
Postato alle 1:21
Lunedì, 28/02/2011
i casi possono essere vari

1. Hai eliminato la cartella Install dalla root del forum?

2. Controlla di aver impostato tutti i permessi necessari per gli utenti ed i visitatori del forum

3. Controlla che il forum non sia impostato su offline

ps. controlla bene la posizione del tuo forum ed il link.
magari hai scritto male il link se non riesci a vedere l'index.php

di solito sarebbe

http://blabla.altervista.org/phpbb/index.php


PM Quote
Avatar
()
Newbie


Messaggi:
Iscritto:

Segnala al moderatore
Postato alle 12:49
Lunedì, 28/02/2011
Testo quotato

Postato originariamente da Thejuster:

i casi possono essere vari

1. Hai eliminato la cartella Install dalla root del forum?

2. Controlla di aver impostato tutti i permessi necessari per gli utenti ed i visitatori del forum

3. Controlla che il forum non sia impostato su offline

ps. controlla bene la posizione del tuo forum ed il link.
magari hai scritto male il link se non riesci a vedere l'index.php

di solito sarebbe

http://blabla.altervista.org/phpbb/index.php


No, grazie era dovuto ai permessi. Con i link di XBarboX me la sono cavata :k:
Il problema non era che non vedevo l'index, era che non mi visualizzava i forum che creavo

Grazie a tutti;)

PM Quote
Avatar
()
Newbie


Messaggi:
Iscritto:

Segnala al moderatore
Postato alle 16:07
Martedì, 01/03/2011
Ultima domanda: se io volessi modificare l'immagine predefinita che utilizza per gli utenti (quella che usa se non mettono un avatar) come faccio?

PM Quote
Avatar
XBarboX (Member)
Guru


Messaggi: 945
Iscritto: 31/12/2008

Segnala al moderatore
Postato alle 17:54
Martedì, 01/03/2011


The old lie: Dulce et decorum est pro patria mori
PM Quote