Questo sito utilizza cookies, anche di terze parti, per mostrare pubblicità e servizi in linea con il tuo account. Leggi l'informativa sui cookies.
Username: Password: oppure
C/C++ - socket
Forum - C/C++ - socket

Avatar
lorenzo (Normal User)
Guru


Messaggi: 1178
Iscritto: 15/04/2008

Segnala al moderatore
Postato alle 11:48
Sabato, 15/11/2008
Da qualche giorno sono alle prese con un problemino usando le winsock.
Il programma deve connettersi al server di posta e scaricare l'ultima mail arrivata per vedere se ne è arrivata una nuova. In quel caso viene segnalato all'utente.

Inizializzo il socket, lo apro,mi connetto e ricevo l'ok in risposta.
Quando tento di mandare un messaggio di USER lo spedisce ma quando attendo la risposta con recv mi si blocca all'infinito...

Cosa potrebbe essere? Io sono dietro ad un router ma non credo che sia questo il problema.
Aiuto!


INCREDIBILE!!!!!!!!!
Ho disabilitato avg e non si blocca più.
Ma adesso mi viene il dubbio che con l'antivirus avviato il prog non funzioni mai.
Voi ne sapete qualcosa?????

Ultima modifica effettuata da lorenzo il 15/11/2008 alle 11:58


"There's no point in being exact about something if you don't even know what you're talking about."

JOHN VON NEUMANN


Siamo italiani NO??
Allora scriviamo in ITALIANO!!!!
PM Quote
Avatar
gioser (Normal User)
Pro


Messaggi: 111
Iscritto: 03/10/2008

Segnala al moderatore
Postato alle 11:30
Lunedì, 17/11/2008

hai provato a vedere cosa succede a livello di pacchetti?

se no prova, ad esempio con wireshark

http://www.wireshark.org/

Ultima modifica effettuata da gioser il 17/11/2008 alle 11:31
PM Quote