Questo sito utilizza cookies, anche di terze parti, per mostrare pubblicità e servizi in linea con il tuo account. Leggi l'informativa sui cookies.
Username: Password: oppure
C# / VB.NET - [VB.Net] WIA & Scanner: problema immagini completamente nere
Forum - C# / VB.NET - [VB.Net] WIA & Scanner: problema immagini completamente nere

Avatar
perfection6989 (Normal User)
Rookie


Messaggi: 38
Iscritto: 14/06/2009

Segnala al moderatore
Postato alle 0:26
Venerdì, 06/12/2013
Sto sviluppando una semplice applicazione per scannerizzare foto e documenti.

Il mio problema è che quando vado a fare la scansione le immagini sono completamente nere.
Tramite Windows Image Acquisition (WIA) setto le seguenti variabili:

Codice sorgente - presumibilmente Delphi

  1. .Properties("6146").Value = colorcode '4 is Black-white,gray is 2, color 1 (Color Intent)
  2.                .Properties("6147").Value = dpi  'dots per inch/horizontal
  3.                 .Properties("6148").Value = dpi 'dots per inch/vertical
  4.                .Properties("6149").Value = 0 'x point where to start scan
  5.                 .Properties("6150").Value = 0 'y-point where to start scan
  6.                .Properties("6154").Value = 0 'brightness
  7.                 .Properties("6155").Value = 0 'contrast
  8.  
  9.                'Following is A4 paper size. (Not 100% accurate because real A4 Ht errors)
  10.                 .Properties("6151").Value = horizextent 'horizontal exent DPI x inches wide
  11.                .Properties("6152").Value = vertextent 'vertical extent DPI x inches tall



Consigli?



p.s.: Lo scanner funziona (ho provato con il programma dell'Hp)

PM Quote
Avatar
perfection6989 (Normal User)
Rookie


Messaggi: 38
Iscritto: 14/06/2009

Segnala al moderatore
Postato alle 0:52
Venerdì, 06/12/2013
rimangio tutto...è lo scanner che non va...prima andava...

PM Quote