Questo sito utilizza cookies, anche di terze parti, per mostrare pubblicità e servizi in linea con il tuo account. Leggi l'informativa sui cookies.
Username: Password: oppure
C# / VB.NET - Coda thread safe
Forum - C# / VB.NET - Coda thread safe

Avatar
XBarboX (Member)
Guru


Messaggi: 945
Iscritto: 31/12/2008

Segnala al moderatore
Postato alle 11:25
Lunedì, 22/08/2011
Ciao a tutti,
avrei bisogno di una coda thread safe in quanto due timer eseguono inserimenti ed estrazioni di elementi in contemporanea.
C'è una classe apposta per il .NET 4.0 ma io ho bisogno che giri su .NET 2.0 e superiore.

Ho trovato questo ma non riesco proprio a capirlo: http://msdn.microsoft.com/en-us/library/system.collections ...

Qualcuno sa darmi una mano?

Grazie mille :k:

p.s. Uso C# 2005, sempre per motivi di compatibilità


The old lie: Dulce et decorum est pro patria mori
PM Quote
Avatar
pierotofy (Admin)
Guru^2


Messaggi: 6109
Iscritto: 04/12/2003

Segnala al moderatore
Postato alle 18:20
Lunedì, 22/08/2011
Curiosita'... perche' deve girare su .NET 2.0?


Seguimi su Twitter: http://www.twitter.com/pierotofy

Fai quello che ti piace, e fallo bene.
PM Quote
Avatar
XBarboX (Member)
Guru


Messaggi: 945
Iscritto: 31/12/2008

Segnala al moderatore
Postato alle 22:25
Lunedì, 22/08/2011
Testo quotato

Postato originariamente da pierotofy:

Curiosita'... perche' deve girare su .NET 2.0?



Devo fare un programma che giri anche sui pc windows server 2003 .
E poi visto che tutte le librerie di cui ho bisogno sono presenti nel .NET 2.0 in su perchè devo andare a sviluppare con un framework maggiore se poi non è supportato?


The old lie: Dulce et decorum est pro patria mori
PM Quote
Avatar
pierotofy (Admin)
Guru^2


Messaggi: 6109
Iscritto: 04/12/2003

Segnala al moderatore
Postato alle 23:46
Lunedì, 22/08/2011
Ma installa il runtime per la versione 4 su Windows Server 2003 scusa... no?


Seguimi su Twitter: http://www.twitter.com/pierotofy

Fai quello che ti piace, e fallo bene.
PM Quote
Avatar
Il Totem (Admin)
Guru^2


Messaggi: 3635
Iscritto: 24/01/2006

Segnala al moderatore
Postato alle 17:36
Domenica, 28/08/2011
Se sviluppi con una versione del framework 2.0 non è detto che sia compatibile con le versioni successive, anche se tutte le librerie che usi esistono ancora. Dipende anche da come vengono referenziati gli assembly nella cache globale. Il loro strong name potrebbe comunque causare un errore di versioning.


"Infelici sono quelli che hanno tanto cervello da vedere la loro stupidità."
(Fligende Blatter)

"Dubitare di se stessi è il primo segno d'intelligenza."
(Ugo Ojetti)
PM Quote